import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s*<wp:postmeta>[^<]*(?:<(?!\\/wp:postmeta>)[^<]*)*<\\/wp:postmeta>)+";
final String string = "<item>\n"
+ " //Start of find\n\n"
+ " <wp:postmeta>\n"
+ " <wp:meta_key><![CDATA[_edit_last]]></wp:meta_key>\n"
+ " <wp:meta_value><![CDATA[3]]></wp:meta_value>\n"
+ " </wp:postmeta>\n"
+ " <wp:postmeta>\n"
+ " <wp:meta_key><![CDATA[_thumbnail_id]]></wp:meta_key>\n"
+ " <wp:meta_value><![CDATA[51833]]></wp:meta_value>\n"
+ " </wp:postmeta>\n"
+ " <wp:postmeta>\n"
+ " <wp:meta_key><![CDATA[snapEdIT]]></wp:meta_key>\n"
+ " <wp:meta_value><![CDATA[1]]></wp:meta_value>\n"
+ " </wp:postmeta>\n\n"
+ " // End of find using Notepad++\n"
+ "</item>\n"
+ "<item>\n"
+ " //Start of find\n\n"
+ " <wp:postmeta>\n"
+ " <wp:meta_key><![CDATA[_edit_last]]></wp:meta_key>\n"
+ " <wp:meta_value><![CDATA[3]]></wp:meta_value>\n"
+ " </wp:postmeta>\n"
+ " <wp:postmeta>\n"
+ " <wp:meta_key><![CDATA[_thumbnail_id]]></wp:meta_key>\n"
+ " <wp:meta_value><![CDATA[51425]]></wp:meta_value>\n"
+ " </wp:postmeta>\n\n"
+ " // End of find using Notepad++\n"
+ "</item>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}