# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\s*<wp:postmeta>[^<]*(?:<(?!\/wp:postmeta>)[^<]*)*<\/wp:postmeta>)+"
test_str = ("<item>\n"
" //Start of find\n\n"
" <wp:postmeta>\n"
" <wp:meta_key><![CDATA[_edit_last]]></wp:meta_key>\n"
" <wp:meta_value><![CDATA[3]]></wp:meta_value>\n"
" </wp:postmeta>\n"
" <wp:postmeta>\n"
" <wp:meta_key><![CDATA[_thumbnail_id]]></wp:meta_key>\n"
" <wp:meta_value><![CDATA[51833]]></wp:meta_value>\n"
" </wp:postmeta>\n"
" <wp:postmeta>\n"
" <wp:meta_key><![CDATA[snapEdIT]]></wp:meta_key>\n"
" <wp:meta_value><![CDATA[1]]></wp:meta_value>\n"
" </wp:postmeta>\n\n"
" // End of find using Notepad++\n"
"</item>\n"
"<item>\n"
" //Start of find\n\n"
" <wp:postmeta>\n"
" <wp:meta_key><![CDATA[_edit_last]]></wp:meta_key>\n"
" <wp:meta_value><![CDATA[3]]></wp:meta_value>\n"
" </wp:postmeta>\n"
" <wp:postmeta>\n"
" <wp:meta_key><![CDATA[_thumbnail_id]]></wp:meta_key>\n"
" <wp:meta_value><![CDATA[51425]]></wp:meta_value>\n"
" </wp:postmeta>\n\n"
" // End of find using Notepad++\n"
"</item>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.