using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?![^<]*>|[^<>]*<\/(?!p\b|td|pre))https?:\/\/[a-z0-9&#=.\/\-?_]+";
string input = @"Posting a link: http://test.com, posting an image <img src=""http://test.com/2.jpg"" />. Posting an actual A tag: <a href=""http://test.com/test.html"">http://test.com/test.html</a>
<p>http://www.link.au</p>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}