import re
regex = re.compile(r"(?![^<]*>|[^<>]*<\/(?!p\b|td|pre))https?:\/\/[a-z0-9&#=.\/\-?_]+", flags=re.IGNORECASE)
test_str = ("Posting a link: http://test.com, posting an image <img src=\"http://test.com/2.jpg\" />. Posting an actual A tag: <a href=\"http://test.com/test.html\">http://test.com/test.html</a>\n"
"<p>http://www.link.au</p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")