using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[!--[^-]*--\](*SKIP)(*F)|(?:(?!\[!--[^-]*--\]).)+";
string input = @"nine hundred ninety [!--$element--] two hundred thirteen";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}