// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([A-Z][a-z]+(\s[A-Z][a-z]+)*)").unwrap();
let string = "127.0.0.1 Amigo 30.08.2012 16:08:13 LOGIN OK
192.168.100.2 Vasya Pupkin 30.08.2012 16:08:40 DONE_TASK 15 OK
146.34.15.5 Eduard Petrovich Morozko 13.09.2013 5:04:50 DOWNLOAD_PLUGIN OK
127.0.0.1 Eduard Petrovich Morozko 11.12.2013 10:11:12 WRITE_MESSAGE FAILED
146.34.15.5 Eduard Petrovich Morozko 12.12.2013 21:56:30 WRITE_MESSAGE OK
146.34.15.5 Eduard Petrovich Morozko 03.01.2014 03:45:23 LOGIN OK
192.168.100.2 Vasya Pupkin 30.01.2014 12:56:22 SOLVE_TASK 18 ERROR
127.0.0.1 Vasya Pupkin 14.11.2015 07:08:01 WRITE_MESSAGE OK
192.168.100.2 Vasya Pupkin 19.03.2016 00:00:00 SOLVE_TASK 1 OK
146.34.15.5 Eduard Petrovich Morozko 05.01.2021 20:22:55 DONE_TASK 48 FAILED
127.0.0.1 Vasya Pupkin 14.10.2021 11:38:21 LOGIN OK
12.12.12.12 Amigo 21.10.2021 19:45:25 SOLVE_TASK 18 OK
120.120.120.122 Amigo 29.2.2028 5:4:7 SOLVE_TASK 18 OK";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}