#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(http|https):\/\/(?:www\.)?puu\.sh\/(\w{5})\/(\w{10})\.(\w{3})"
Local $sString = "https://puu.sh/qpMlC/b58dea7700.png" & @CRLF & _
"http://puu.sh/qpDOW/eb0ba4f4b2.jpg" & @CRLF & _
"http://puu.sh/qpPfI/b74edd1b8e.png"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")