package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^:]+):([\w\d-\.]+)`)
var str = `PatientID:2025
PlanName:p1b1d1a
PlanUID:1.2.246.352.71.5.78480665410.384135.20151228085931
BeamNumber:2
BeamName:CCW
OriginalMU:1995.39040729
LoggingScale:IEC1217
X1(Cms):-2.50
X2(Cms):+2.20
Y1(Cms):-2.60
Y2(Cms):+2.50
GantryRotationAngle(deg):87.73
Energy:6x
MU1:1007.63
MU2:1009.05
RadiationTime(mins):1.6807
DoseRate(MU/min):598.32
PFNHighVoltagePowerSupplyCurrent(A):1.908875
PFNActualVoltage(KV):18.21791
RFDriverVoltage(V):4.365
RFForwardPower(W):1.516418
AFCError(V):-0.000601778
GunCurrent(A):0.3430939
GunHighVoltage(V):-14965
GunGridVoltage(V):97.55565
GunFilamentStepVoltage(V):5.300003
GunFilamentVoltage(V):5.405273
BendMagnetCurrent(A):16.18042
BendMagnetVoltage(V):2.283325
AcceleratorSolenoidCurrent(A):34.95636
KlystronSolenoidCurrent(A):34.95789
RadialSymmetry(%):0.00045321
TransverseSymmetry(%):0.00044355
TargetCurrent(nC):315.4927
BuncherRadialCurrent(A):0.005020142
BuncherTransverseCurrent(A):-0.06005859
AngleRadialCurrent(A):0.005279541
AngleTransverseCurrent(A):0.06143188
PositionRadialCurrent(A):-0.8885803
PositionTransverseCurrent(A):-0.5808258
Trim:(A)-0.06399536
AcceleratorVacionCurrent(uA):0.009002686
Positive5Vdc:4.993916
Positive24Vdc:24.4706
AnalogNegative5Vdc:5.054981
AnalogPositive5Vdc:4.97241
Negative12Vdc:12.24357
Positive3Vdc:3.303525
NodePowerSupplyVoltage(V):24.58121
WaterLevel:Normal
CityWaterTemperature(degC):20.54332
InternalWaterSupplyTemperature(degC):40.51909
GasPressure(PSI):32.3421
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}