# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([^:]+):([\w\d-\.]+)"
test_str = ("PatientID:2025\n"
"PlanName:p1b1d1a\n"
"PlanUID:1.2.246.352.71.5.78480665410.384135.20151228085931\n"
"BeamNumber:2\n"
"BeamName:CCW\n"
"OriginalMU:1995.39040729\n\n"
"LoggingScale:IEC1217\n"
"X1(Cms):-2.50\n"
"X2(Cms):+2.20\n"
"Y1(Cms):-2.60\n"
"Y2(Cms):+2.50\n"
"GantryRotationAngle(deg):87.73\n"
"Energy:6x\n"
"MU1:1007.63\n"
"MU2:1009.05\n"
"RadiationTime(mins):1.6807\n"
"DoseRate(MU/min):598.32\n"
"PFNHighVoltagePowerSupplyCurrent(A):1.908875\n"
"PFNActualVoltage(KV):18.21791\n"
"RFDriverVoltage(V):4.365\n"
"RFForwardPower(W):1.516418\n"
"AFCError(V):-0.000601778\n"
"GunCurrent(A):0.3430939\n"
"GunHighVoltage(V):-14965\n"
"GunGridVoltage(V):97.55565\n"
"GunFilamentStepVoltage(V):5.300003\n"
"GunFilamentVoltage(V):5.405273\n"
"BendMagnetCurrent(A):16.18042\n"
"BendMagnetVoltage(V):2.283325\n"
"AcceleratorSolenoidCurrent(A):34.95636\n"
"KlystronSolenoidCurrent(A):34.95789\n"
"RadialSymmetry(%):0.00045321\n"
"TransverseSymmetry(%):0.00044355\n"
"TargetCurrent(nC):315.4927\n"
"BuncherRadialCurrent(A):0.005020142\n"
"BuncherTransverseCurrent(A):-0.06005859\n"
"AngleRadialCurrent(A):0.005279541\n"
"AngleTransverseCurrent(A):0.06143188\n"
"PositionRadialCurrent(A):-0.8885803\n"
"PositionTransverseCurrent(A):-0.5808258\n"
"Trim:(A)-0.06399536\n"
"AcceleratorVacionCurrent(uA):0.009002686\n"
"Positive5Vdc:4.993916\n"
"Positive24Vdc:24.4706\n"
"AnalogNegative5Vdc:5.054981\n"
"AnalogPositive5Vdc:4.97241\n"
"Negative12Vdc:12.24357\n"
"Positive3Vdc:3.303525\n"
"NodePowerSupplyVoltage(V):24.58121\n"
"WaterLevel:Normal\n"
"CityWaterTemperature(degC):20.54332\n"
"InternalWaterSupplyTemperature(degC):40.51909\n"
"GasPressure(PSI):32.3421\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.