import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<project>\\w+)-(?<core>\\d+\\.x)-(?<major>\\d+)\\.(?<patch>[\\dx]+)[-\\.]?(?<extra>[^\\.]+)?\\.(tar\\.gz|tgz)$\n";
final String string = "pkgdeploy-7.x-1.2.1.tar.gz\n"
+ "styles-7.x-2.x-dev.tar.gz\n"
+ "esi-7.x-3.0-alpha1+11-dev.tar.gz\n"
+ "views-7.x-2.1.tar.gz\n"
+ "views_ui-7.x-2.1.tar.gz\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}