import re
regex = re.compile((r"^(?<project>\w+)-(?<core>\d+\.x)-(?<major>\d+)\.(?<patch>[\dx]+)[-\.]?(?<extra>[^\.]+)?\.(tar\.gz|tgz)$\n"), flags=re.MULTILINE)
test_str = ("pkgdeploy-7.x-1.2.1.tar.gz\n"
"styles-7.x-2.x-dev.tar.gz\n"
"esi-7.x-3.0-alpha1+11-dev.tar.gz\n"
"views-7.x-2.1.tar.gz\n"
"views_ui-7.x-2.1.tar.gz\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")