$re = '/^\d{3}(?:$|\s)(?:([ACERV])(?!\1)|\s(?!$|\1))*$/m';
$str = '123
123 A
123 A V
123 CER
123 V V
Invalid formats:
123A
123 AA
123 A ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);