import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z](?=[a-zA-Z'-]{3})|\\b[a-z](?=[a-zA-Z'-]{3,}$)|['-][a-z]";
final String string = "anne-marie\n"
+ "vom schattenreich\n"
+ "will it work-or-not\n"
+ "seth o'callaghan\n"
+ "first and last only\n"
+ "sarah jane o'brien";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}