$re = '/^[a-z](?=[a-zA-Z\'-]{3})|\b[a-z](?=[a-zA-Z\'-]{3,}$)|[\'-][a-z]/m';
$str = 'anne-marie
vom schattenreich
will it work-or-not
seth o\'callaghan
first and last only
sarah jane o\'brien';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);