#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(America\/Adak|America\/Anchorage|America\/Anguilla|America\/Antigua|America\/Araguaina|America\/Argentina\/Buenos_Aires|America\/Argentina\/Catamarca|America\/Argentina\/Cordoba|America\/Argentina\/Jujuy|America\/Argentina\/La_Rioja|America\/Argentina\/Mendoza|America\/Argentina\/Rio_Gallegos|America\/Argentina\/Salta|America\/Argentina\/San_Juan|America\/Argentina\/San_Luis|America\/Argentina\/Tucuman|America\/Argentina\/Ushuaia|America\/Aruba|America\/Asuncion|America\/Atikokan|America\/Bahia|America\/Bahia_Banderas|America\/Barbados|America\/Belem|America\/Belize|America\/Blanc-Sablon|America\/Boa_Vista|America\/Bogota|America\/Boise|America\/Cambridge_Bay|America\/Campo_Grande|America\/Cancun|America\/Caracas|America\/Cayenne|America\/Cayman|America\/Chicago|America\/Chihuahua|America\/Ciudad_Juarez|America\/Costa_Rica|America\/Coyhaique|America\/Creston|America\/Cuiaba|America\/Curacao|America\/Danmarkshavn|America\/Dawson|America\/Dawson_Creek|America\/Denver|America\/Detroit|America\/Dominica|America\/Edmonton|America\/Eirunepe|America\/El_Salvador|America\/Fort_Nelson|America\/Fortaleza|America\/Glace_Bay|America\/Goose_Bay|America\/Grand_Turk|America\/Grenada|America\/Guadeloupe|America\/Guatemala|America\/Guayaquil|America\/Guyana|America\/Halifax|America\/Havana|America\/Hermosillo|America\/Indiana\/Indianapolis|America\/Indiana\/Knox|America\/Indiana\/Marengo|America\/Indiana\/Petersburg|America\/Indiana\/Tell_City|America\/Indiana\/Vevay|America\/Indiana\/Vincennes|America\/Indiana\/Winamac|America\/Inuvik|America\/Iqaluit|America\/Jamaica|America\/Juneau|America\/Kentucky\/Louisville|America\/Kentucky\/Monticello|America\/Kralendijk|America\/La_Paz|America\/Lima|America\/Los_Angeles|America\/Lower_Princes|America\/Maceio|America\/Managua|America\/Manaus|America\/Marigot|America\/Martinique|America\/Matamoros|America\/Mazatlan|America\/Menominee|America\/Merida|America\/Metlakatla|America\/Mexico_City|America\/Miquelon|America\/Moncton|America\/Monterrey|America\/Montevideo|America\/Montserrat|America\/Nassau|America\/New_York|America\/Nome|America\/Noronha|America\/North_Dakota\/Beulah|America\/North_Dakota\/Center|America\/North_Dakota\/New_Salem|America\/Nuuk|America\/Ojinaga|America\/Panama|America\/Paramaribo|America\/Phoenix|America\/Port-au-Prince|America\/Port_of_Spain|America\/Porto_Velho|America\/Puerto_Rico|America\/Punta_Arenas|America\/Rankin_Inlet|America\/Recife|America\/Regina|America\/Resolute|America\/Rio_Branco|America\/Santarem|America\/Santiago|America\/Santo_Domingo|America\/Sao_Paulo|America\/Scoresbysund|America\/Sitka|America\/St_Barthelemy|America\/St_Johns|America\/St_Kitts|America\/St_Lucia|America\/St_Thomas|America\/St_Vincent|America\/Swift_Current|America\/Tegucigalpa|America\/Thule|America\/Tijuana|America\/Toronto|America\/Tortola|America\/Vancouver|America\/Whitehorse|America\/Winnipeg|America\/Yakutat)"
Local $sString = "America/Adak" & @CRLF & _
"America/Anchorage" & @CRLF & _
"America/Anguilla" & @CRLF & _
"America/Antigua" & @CRLF & _
"America/Araguaina" & @CRLF & _
"America/Argentina/Buenos_Aires" & @CRLF & _
"America/Argentina/Catamarca" & @CRLF & _
"America/Argentina/ComodRivadavia" & @CRLF & _
"America/Argentina/Cordoba" & @CRLF & _
"America/Argentina/Jujuy" & @CRLF & _
"America/Argentina/La_Rioja" & @CRLF & _
"America/Argentina/Mendoza" & @CRLF & _
"America/Argentina/Rio_Gallegos" & @CRLF & _
"America/Argentina/Salta" & @CRLF & _
"America/Argentina/San_Juan" & @CRLF & _
"America/Argentina/San_Luis" & @CRLF & _
"America/Argentina/Tucuman" & @CRLF & _
"America/Argentina/Ushuaia" & @CRLF & _
"America/Aruba" & @CRLF & _
"America/Asuncion" & @CRLF & _
"America/Atikokan" & @CRLF & _
"America/Atka" & @CRLF & _
"America/Bahia" & @CRLF & _
"America/Bahia_Banderas" & @CRLF & _
"America/Barbados" & @CRLF & _
"America/Belem" & @CRLF & _
"America/Belize" & @CRLF & _
"America/Blanc-Sablon" & @CRLF & _
"America/Boa_Vista" & @CRLF & _
"America/Bogota" & @CRLF & _
"America/Boise" & @CRLF & _
"America/Buenos_Aires" & @CRLF & _
"America/Cambridge_Bay" & @CRLF & _
"America/Campo_Grande" & @CRLF & _
"America/Cancun" & @CRLF & _
"America/Caracas" & @CRLF & _
"America/Catamarca" & @CRLF & _
"America/Cayenne" & @CRLF & _
"America/Cayman" & @CRLF & _
"America/Chicago" & @CRLF & _
"America/Chihuahua" & @CRLF & _
"America/Ciudad_Juarez" & @CRLF & _
"America/Coral_Harbour" & @CRLF & _
"America/Cordoba" & @CRLF & _
"America/Costa_Rica" & @CRLF & _
"America/Coyhaique" & @CRLF & _
"America/Creston" & @CRLF & _
"America/Cuiaba" & @CRLF & _
"America/Curacao" & @CRLF & _
"America/Danmarkshavn" & @CRLF & _
"America/Dawson" & @CRLF & _
"America/Dawson_Creek" & @CRLF & _
"America/Denver" & @CRLF & _
"America/Detroit" & @CRLF & _
"America/Dominica" & @CRLF & _
"America/Edmonton" & @CRLF & _
"America/Eirunepe" & @CRLF & _
"America/El_Salvador" & @CRLF & _
"America/Ensenada" & @CRLF & _
"America/Fort_Nelson" & @CRLF & _
"America/Fort_Wayne" & @CRLF & _
"America/Fortaleza" & @CRLF & _
"America/Glace_Bay" & @CRLF & _
"America/Godthab" & @CRLF & _
"America/Goose_Bay" & @CRLF & _
"America/Grand_Turk" & @CRLF & _
"America/Grenada" & @CRLF & _
"America/Guadeloupe" & @CRLF & _
"America/Guatemala" & @CRLF & _
"America/Guayaquil" & @CRLF & _
"America/Guyana" & @CRLF & _
"America/Halifax" & @CRLF & _
"America/Havana" & @CRLF & _
"America/Hermosillo" & @CRLF & _
"America/Indiana/Indianapolis" & @CRLF & _
"America/Indiana/Knox" & @CRLF & _
"America/Indiana/Marengo" & @CRLF & _
"America/Indiana/Petersburg" & @CRLF & _
"America/Indiana/Tell_City" & @CRLF & _
"America/Indiana/Vevay" & @CRLF & _
"America/Indiana/Vincennes" & @CRLF & _
"America/Indiana/Winamac" & @CRLF & _
"America/Indianapolis" & @CRLF & _
"America/Inuvik" & @CRLF & _
"America/Iqaluit" & @CRLF & _
"America/Jamaica" & @CRLF & _
"America/Jujuy" & @CRLF & _
"America/Juneau" & @CRLF & _
"America/Kentucky/Louisville" & @CRLF & _
"America/Kentucky/Monticello" & @CRLF & _
"America/Knox_IN" & @CRLF & _
"America/Kralendijk" & @CRLF & _
"America/La_Paz" & @CRLF & _
"America/Lima" & @CRLF & _
"America/Los_Angeles" & @CRLF & _
"America/Louisville" & @CRLF & _
"America/Lower_Princes" & @CRLF & _
"America/Maceio" & @CRLF & _
"America/Managua" & @CRLF & _
"America/Manaus" & @CRLF & _
"America/Marigot" & @CRLF & _
"America/Martinique" & @CRLF & _
"America/Matamoros" & @CRLF & _
"America/Mazatlan" & @CRLF & _
"America/Mendoza" & @CRLF & _
"America/Menominee" & @CRLF & _
"America/Merida" & @CRLF & _
"America/Metlakatla" & @CRLF & _
"America/Mexico_City" & @CRLF & _
"America/Miquelon" & @CRLF & _
"America/Moncton" & @CRLF & _
"America/Monterrey" & @CRLF & _
"America/Montevideo" & @CRLF & _
"America/Montreal" & @CRLF & _
"America/Montserrat" & @CRLF & _
"America/Nassau" & @CRLF & _
"America/New_York" & @CRLF & _
"America/Nipigon" & @CRLF & _
"America/Nome" & @CRLF & _
"America/Noronha" & @CRLF & _
"America/North_Dakota/Beulah" & @CRLF & _
"America/North_Dakota/Center" & @CRLF & _
"America/North_Dakota/New_Salem" & @CRLF & _
"America/Nuuk" & @CRLF & _
"America/Ojinaga" & @CRLF & _
"America/Panama" & @CRLF & _
"America/Pangnirtung" & @CRLF & _
"America/Paramaribo" & @CRLF & _
"America/Phoenix" & @CRLF & _
"America/Port-au-Prince" & @CRLF & _
"America/Port_of_Spain" & @CRLF & _
"America/Porto_Acre" & @CRLF & _
"America/Porto_Velho" & @CRLF & _
"America/Puerto_Rico" & @CRLF & _
"America/Punta_Arenas" & @CRLF & _
"America/Rainy_River" & @CRLF & _
"America/Rankin_Inlet" & @CRLF & _
"America/Recife" & @CRLF & _
"America/Regina" & @CRLF & _
"America/Resolute" & @CRLF & _
"America/Rio_Branco" & @CRLF & _
"America/Rosario" & @CRLF & _
"America/Santa_Isabel" & @CRLF & _
"America/Santarem" & @CRLF & _
"America/Santiago" & @CRLF & _
"America/Santo_Domingo" & @CRLF & _
"America/Sao_Paulo" & @CRLF & _
"America/Scoresbysund" & @CRLF & _
"America/Shiprock" & @CRLF & _
"America/Sitka" & @CRLF & _
"America/St_Barthelemy" & @CRLF & _
"America/St_Johns" & @CRLF & _
"America/St_Kitts" & @CRLF & _
"America/St_Lucia" & @CRLF & _
"America/St_Thomas" & @CRLF & _
"America/St_Vincent" & @CRLF & _
"America/Swift_Current" & @CRLF & _
"America/Tegucigalpa" & @CRLF & _
"America/Thule" & @CRLF & _
"America/Thunder_Bay" & @CRLF & _
"America/Tijuana" & @CRLF & _
"America/Toronto" & @CRLF & _
"America/Tortola" & @CRLF & _
"America/Vancouver" & @CRLF & _
"America/Virgin" & @CRLF & _
"America/Whitehorse" & @CRLF & _
"America/Winnipeg" & @CRLF & _
"America/Yakutat" & @CRLF & _
"America/Yellowknife" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")