import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(America\\/Adak|America\\/Anchorage|America\\/Anguilla|America\\/Antigua|America\\/Araguaina|America\\/Argentina\\/Buenos_Aires|America\\/Argentina\\/Catamarca|America\\/Argentina\\/Cordoba|America\\/Argentina\\/Jujuy|America\\/Argentina\\/La_Rioja|America\\/Argentina\\/Mendoza|America\\/Argentina\\/Rio_Gallegos|America\\/Argentina\\/Salta|America\\/Argentina\\/San_Juan|America\\/Argentina\\/San_Luis|America\\/Argentina\\/Tucuman|America\\/Argentina\\/Ushuaia|America\\/Aruba|America\\/Asuncion|America\\/Atikokan|America\\/Bahia|America\\/Bahia_Banderas|America\\/Barbados|America\\/Belem|America\\/Belize|America\\/Blanc-Sablon|America\\/Boa_Vista|America\\/Bogota|America\\/Boise|America\\/Cambridge_Bay|America\\/Campo_Grande|America\\/Cancun|America\\/Caracas|America\\/Cayenne|America\\/Cayman|America\\/Chicago|America\\/Chihuahua|America\\/Ciudad_Juarez|America\\/Costa_Rica|America\\/Coyhaique|America\\/Creston|America\\/Cuiaba|America\\/Curacao|America\\/Danmarkshavn|America\\/Dawson|America\\/Dawson_Creek|America\\/Denver|America\\/Detroit|America\\/Dominica|America\\/Edmonton|America\\/Eirunepe|America\\/El_Salvador|America\\/Fort_Nelson|America\\/Fortaleza|America\\/Glace_Bay|America\\/Goose_Bay|America\\/Grand_Turk|America\\/Grenada|America\\/Guadeloupe|America\\/Guatemala|America\\/Guayaquil|America\\/Guyana|America\\/Halifax|America\\/Havana|America\\/Hermosillo|America\\/Indiana\\/Indianapolis|America\\/Indiana\\/Knox|America\\/Indiana\\/Marengo|America\\/Indiana\\/Petersburg|America\\/Indiana\\/Tell_City|America\\/Indiana\\/Vevay|America\\/Indiana\\/Vincennes|America\\/Indiana\\/Winamac|America\\/Inuvik|America\\/Iqaluit|America\\/Jamaica|America\\/Juneau|America\\/Kentucky\\/Louisville|America\\/Kentucky\\/Monticello|America\\/Kralendijk|America\\/La_Paz|America\\/Lima|America\\/Los_Angeles|America\\/Lower_Princes|America\\/Maceio|America\\/Managua|America\\/Manaus|America\\/Marigot|America\\/Martinique|America\\/Matamoros|America\\/Mazatlan|America\\/Menominee|America\\/Merida|America\\/Metlakatla|America\\/Mexico_City|America\\/Miquelon|America\\/Moncton|America\\/Monterrey|America\\/Montevideo|America\\/Montserrat|America\\/Nassau|America\\/New_York|America\\/Nome|America\\/Noronha|America\\/North_Dakota\\/Beulah|America\\/North_Dakota\\/Center|America\\/North_Dakota\\/New_Salem|America\\/Nuuk|America\\/Ojinaga|America\\/Panama|America\\/Paramaribo|America\\/Phoenix|America\\/Port-au-Prince|America\\/Port_of_Spain|America\\/Porto_Velho|America\\/Puerto_Rico|America\\/Punta_Arenas|America\\/Rankin_Inlet|America\\/Recife|America\\/Regina|America\\/Resolute|America\\/Rio_Branco|America\\/Santarem|America\\/Santiago|America\\/Santo_Domingo|America\\/Sao_Paulo|America\\/Scoresbysund|America\\/Sitka|America\\/St_Barthelemy|America\\/St_Johns|America\\/St_Kitts|America\\/St_Lucia|America\\/St_Thomas|America\\/St_Vincent|America\\/Swift_Current|America\\/Tegucigalpa|America\\/Thule|America\\/Tijuana|America\\/Toronto|America\\/Tortola|America\\/Vancouver|America\\/Whitehorse|America\\/Winnipeg|America\\/Yakutat)";
final String string = "America/Adak\n"
+ "America/Anchorage\n"
+ "America/Anguilla\n"
+ "America/Antigua\n"
+ "America/Araguaina\n"
+ "America/Argentina/Buenos_Aires\n"
+ "America/Argentina/Catamarca\n"
+ "America/Argentina/ComodRivadavia\n"
+ "America/Argentina/Cordoba\n"
+ "America/Argentina/Jujuy\n"
+ "America/Argentina/La_Rioja\n"
+ "America/Argentina/Mendoza\n"
+ "America/Argentina/Rio_Gallegos\n"
+ "America/Argentina/Salta\n"
+ "America/Argentina/San_Juan\n"
+ "America/Argentina/San_Luis\n"
+ "America/Argentina/Tucuman\n"
+ "America/Argentina/Ushuaia\n"
+ "America/Aruba\n"
+ "America/Asuncion\n"
+ "America/Atikokan\n"
+ "America/Atka\n"
+ "America/Bahia\n"
+ "America/Bahia_Banderas\n"
+ "America/Barbados\n"
+ "America/Belem\n"
+ "America/Belize\n"
+ "America/Blanc-Sablon\n"
+ "America/Boa_Vista\n"
+ "America/Bogota\n"
+ "America/Boise\n"
+ "America/Buenos_Aires\n"
+ "America/Cambridge_Bay\n"
+ "America/Campo_Grande\n"
+ "America/Cancun\n"
+ "America/Caracas\n"
+ "America/Catamarca\n"
+ "America/Cayenne\n"
+ "America/Cayman\n"
+ "America/Chicago\n"
+ "America/Chihuahua\n"
+ "America/Ciudad_Juarez\n"
+ "America/Coral_Harbour\n"
+ "America/Cordoba\n"
+ "America/Costa_Rica\n"
+ "America/Coyhaique\n"
+ "America/Creston\n"
+ "America/Cuiaba\n"
+ "America/Curacao\n"
+ "America/Danmarkshavn\n"
+ "America/Dawson\n"
+ "America/Dawson_Creek\n"
+ "America/Denver\n"
+ "America/Detroit\n"
+ "America/Dominica\n"
+ "America/Edmonton\n"
+ "America/Eirunepe\n"
+ "America/El_Salvador\n"
+ "America/Ensenada\n"
+ "America/Fort_Nelson\n"
+ "America/Fort_Wayne\n"
+ "America/Fortaleza\n"
+ "America/Glace_Bay\n"
+ "America/Godthab\n"
+ "America/Goose_Bay\n"
+ "America/Grand_Turk\n"
+ "America/Grenada\n"
+ "America/Guadeloupe\n"
+ "America/Guatemala\n"
+ "America/Guayaquil\n"
+ "America/Guyana\n"
+ "America/Halifax\n"
+ "America/Havana\n"
+ "America/Hermosillo\n"
+ "America/Indiana/Indianapolis\n"
+ "America/Indiana/Knox\n"
+ "America/Indiana/Marengo\n"
+ "America/Indiana/Petersburg\n"
+ "America/Indiana/Tell_City\n"
+ "America/Indiana/Vevay\n"
+ "America/Indiana/Vincennes\n"
+ "America/Indiana/Winamac\n"
+ "America/Indianapolis\n"
+ "America/Inuvik\n"
+ "America/Iqaluit\n"
+ "America/Jamaica\n"
+ "America/Jujuy\n"
+ "America/Juneau\n"
+ "America/Kentucky/Louisville\n"
+ "America/Kentucky/Monticello\n"
+ "America/Knox_IN\n"
+ "America/Kralendijk\n"
+ "America/La_Paz\n"
+ "America/Lima\n"
+ "America/Los_Angeles\n"
+ "America/Louisville\n"
+ "America/Lower_Princes\n"
+ "America/Maceio\n"
+ "America/Managua\n"
+ "America/Manaus\n"
+ "America/Marigot\n"
+ "America/Martinique\n"
+ "America/Matamoros\n"
+ "America/Mazatlan\n"
+ "America/Mendoza\n"
+ "America/Menominee\n"
+ "America/Merida\n"
+ "America/Metlakatla\n"
+ "America/Mexico_City\n"
+ "America/Miquelon\n"
+ "America/Moncton\n"
+ "America/Monterrey\n"
+ "America/Montevideo\n"
+ "America/Montreal\n"
+ "America/Montserrat\n"
+ "America/Nassau\n"
+ "America/New_York\n"
+ "America/Nipigon\n"
+ "America/Nome\n"
+ "America/Noronha\n"
+ "America/North_Dakota/Beulah\n"
+ "America/North_Dakota/Center\n"
+ "America/North_Dakota/New_Salem\n"
+ "America/Nuuk\n"
+ "America/Ojinaga\n"
+ "America/Panama\n"
+ "America/Pangnirtung\n"
+ "America/Paramaribo\n"
+ "America/Phoenix\n"
+ "America/Port-au-Prince\n"
+ "America/Port_of_Spain\n"
+ "America/Porto_Acre\n"
+ "America/Porto_Velho\n"
+ "America/Puerto_Rico\n"
+ "America/Punta_Arenas\n"
+ "America/Rainy_River\n"
+ "America/Rankin_Inlet\n"
+ "America/Recife\n"
+ "America/Regina\n"
+ "America/Resolute\n"
+ "America/Rio_Branco\n"
+ "America/Rosario\n"
+ "America/Santa_Isabel\n"
+ "America/Santarem\n"
+ "America/Santiago\n"
+ "America/Santo_Domingo\n"
+ "America/Sao_Paulo\n"
+ "America/Scoresbysund\n"
+ "America/Shiprock\n"
+ "America/Sitka\n"
+ "America/St_Barthelemy\n"
+ "America/St_Johns\n"
+ "America/St_Kitts\n"
+ "America/St_Lucia\n"
+ "America/St_Thomas\n"
+ "America/St_Vincent\n"
+ "America/Swift_Current\n"
+ "America/Tegucigalpa\n"
+ "America/Thule\n"
+ "America/Thunder_Bay\n"
+ "America/Tijuana\n"
+ "America/Toronto\n"
+ "America/Tortola\n"
+ "America/Vancouver\n"
+ "America/Virgin\n"
+ "America/Whitehorse\n"
+ "America/Winnipeg\n"
+ "America/Yakutat\n"
+ "America/Yellowknife\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}