import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?! \\*).*";
final String string = " *borrada\n"
+ " *Presente por tres espacios\n"
+ " *presente por dos espacios\n"
+ "presente\n"
+ " *tambien borrada\n"
+ " tambien presente\n"
+ "tambien esto esta presente";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}