import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:Accept|Integrate)\\s*$";
final String string = "c:/project1/main/Node/Accept/testCase1/Browse.c\n"
+ "c:/project1/main/Node/Accept/testCase2/navigate.c\n"
+ "c:/project1/main/Node/Accept/testCase2/save.c\n"
+ "c:/project1/main/Node/Accept/testCase4/search.c\n"
+ "c:/project1/main/Node/Accept\n"
+ "c:/project1/main/Node/Integrate\n"
+ "c:/project1/main/Node/Accept/destroy/fullCoverage/remove.py\n"
+ "c:/project1/main/Tree/Integrate/testCase1/Browse.c\n"
+ "c:/project1/main/Tree/Integrate";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}