# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:Accept|Integrate)\s*$"
test_str = ("c:/project1/main/Node/Accept/testCase1/Browse.c\n"
"c:/project1/main/Node/Accept/testCase2/navigate.c\n"
"c:/project1/main/Node/Accept/testCase2/save.c\n"
"c:/project1/main/Node/Accept/testCase4/search.c\n"
"c:/project1/main/Node/Accept\n"
"c:/project1/main/Node/Integrate\n"
"c:/project1/main/Node/Accept/destroy/fullCoverage/remove.py\n"
"c:/project1/main/Tree/Integrate/testCase1/Browse.c\n"
"c:/project1/main/Tree/Integrate")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.