package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\w|[\.\-_~:])+$`)
var str = `ref:1234
ref_1234
ref-1234
ref~1234
ref.1234
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}