$re = '/^(\w|[\.\-_~:])+$/m';
$str = 'ref:1234
ref_1234
ref-1234
ref~1234
ref.1234
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);