use strict;
my $str = 'DOCTYPE html
html
head
title gulp-gotohead
style.
article {border:1px solid}
style(data-above-the-fold="true").
body {font-size:100%}
body{font-size:100%}
body.main{font-size:100%}
body, h1{font-size:100%}
body>h1{font-size:100%}
header {color:#333}
script(data-above-the-fold="true").
var head = Head();
head();
body (data-d="true")
h1 gulp-gotohead
p
span regex';
my $regex = qr/^(\s*)style\(data-above-the-fold="true"\)\.\n(\1\s+.*\n)*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}