import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[A-Z]_[A-Z]*|[0-9]+)(?:,(?:[A-Z]_[A-Z]*|[0-9]+))*$";
final String string = "A_AAAAA,B_BBBBB,122334,D_DFDFDF\n"
+ "12345,123567,123456,A_BBBBB,C_DDDDD,1234567\n"
+ "RR_RRR,12345\n"
+ "1_111,AVSFFF,\n"
+ "A_SDDF,,123342";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}