re = /^(?:[A-Z]_[A-Z]*|[0-9]+)(?:,(?:[A-Z]_[A-Z]*|[0-9]+))*$/m
str = 'A_AAAAA,B_BBBBB,122334,D_DFDFDF
12345,123567,123456,A_BBBBB,C_DDDDD,1234567
RR_RRR,12345
1_111,AVSFFF,
A_SDDF,,123342'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end