const regex = /data-image="(\d+)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('data-image="(\\d+)"', 'gm')
const str = `<img src="33d4f059af1.jpg" data-image="13405"><img src="33d4f059af1.jpg" data-image="13406">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}