$re = '/data-image="(\d+)"/m';
$str = '<img src="33d4f059af1.jpg" data-image="13405"><img src="33d4f059af1.jpg" data-image="13406">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);