$re = '~<p class="mb-40px">[^<>]*</p>\R?(*SKIP)(*F)|.~ms';
$str = '<p class="mb-40px"></g></svg> </a>
</li>
</ul>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="comment-form-fields">
<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
<p class="comment-form-posting-as pa-wordpress">
Comentezi folosind contul tău WordPress.com. <span class="comment-form-log-out">
( <a href="javascript:HighlanderComments.doExternalLogout( \'wordpress\' );">Dezautentificare</a> /
<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Schimbă</a> )
</span>
</p>
<p class="mb-40px">
Comentezi folosind contul tău Google. <span class="comment-form-log-out">
( <a href="javascript:HighlanderComments.doExternalLogout( \'googleplus\' );">Dezautentificare</a> /
<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Schimbă</a> )
</span>
</p>
<p class="mb-40px">
Comentezi folosind contul tău Twitter. <span class="comment-form-log-out">
( <a href="javascript:HighlanderComments.doExternalLogout( \'twitter\' );">Dezautentificare</a> /
<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Schimbă</a> )
</span>
</p>
<p class="mb-40px">
Comentezi folosind contul tău Facebook. <span class="comment-form-log-out">
( <a href="javascript:HighlanderComments.doExternalLogout( \'facebook\' );">Dezautentificare</a> /
<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Schimbă</a> )
</span>
</p>
<p class="mb-40px">Foarte frumos lucru</p>
<p class="mb-40px">I love cars</p>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;