package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)/begin\s+MEASUREMENT\s+(?P<name1>[\w.]+)\W.*\nSWORD\s+(?P<name2>[\w.]+)\W.+\s+(?P<digit1>-\d.+|\d.+)\s+(?P<digit2>-\d.+|\d.+)`)
var str = `/begin MEASUREMENT ANY.NAME1 "Unterstützungskraft Softwaremodul "
SWORD ANYN.AME2 1 100 -2342342523 2432343535654`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}