$re = '//begin\s+MEASUREMENT\s+(?P<name1>[\w.]+)\W.*\nSWORD\s+(?P<name2>[\w.]+)\W.+\s+(?P<digit1>-\d.+|\d.+)\s+(?P<digit2>-\d.+|\d.+)/m';
$str = '/begin MEASUREMENT ANY.NAME1 "Unterstützungskraft Softwaremodul "
SWORD ANYN.AME2 1 100 -2342342523 2432343535654';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);