import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(?=<)(?:(?=.*?<(?!.*?\\1)(.*>(?!.*\\2).*))(?=.*?>(?!.*?\\2)(.*)).)+?.*?(?=\\1)[^<]*(?=\\2$)";
final String string = "<F<i<r<s>t>>> <<S><e><<c><o>><n>d> <<<<<<<Third>>>>>>>\n\n\n"
+ "<<123>,<456>,<789>>\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}