$re = '/(?s)(?=<)(?:(?=.*?<(?!.*?\1)(.*>(?!.*\2).*))(?=.*?>(?!.*?\2)(.*)).)+?.*?(?=\1)[^<]*(?=\2$)/';
$str = '<F<i<r<s>t>>> <<S><e><<c><o>><n>d> <<<<<<<Third>>>>>>>
<<123>,<456>,<789>>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);