import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bMAKRO\\s(?!DEBTORS)";
final String string = "MAKRO AMANZIMTOTI\n"
+ "346733 MAKRO LI\n"
+ "C#MAKRO STRUBENS VALLE\n"
+ "MAKRO DEBTORS WOODME";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}