$re = '/\bMAKRO\s(?!DEBTORS)/m';
$str = 'MAKRO AMANZIMTOTI
346733 MAKRO LI
C#MAKRO STRUBENS VALLE
MAKRO DEBTORS WOODME';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);