using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"조\s{0,999}성\s{0,999}우";
string input = @"조 성 우";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}