import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https:\\/\\/provider.sharespaceapp.swisscom.com((?!:(443|80)(($)|(\\/))))(?:(?:(?::)(\\d*)))?(?:(?:(\\/latest)(?=\\/))|(?:(\\/latest)($)))?)";
final String string = "https://provider.sharespaceapp.swisscom.com:44303/latest/scripts/sharespace.js";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}