re = /(https:\/\/provider.sharespaceapp.swisscom.com((?!:(443|80)(($)|(\/))))(?:(?:(?::)(\d*)))?(?:(?:(\/latest)(?=\/))|(?:(\/latest)($)))?)/
str = 'https://provider.sharespaceapp.swisscom.com:44303/latest/scripts/sharespace.js'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end