#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)##(.*?)##"
Local $sString = "This is some text " & @CRLF & _
"<p>##IDOBJECT=784##</p> and another some text " & @CRLF & _
"<p>##IDOBJECT=1509##</p>" & @CRLF & _
"<p>##LATESTARTICLESHOME=321##</p>" & @CRLF & _
"<p align=\"center\">##IDOBJECT=321##</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")