package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)##(.*?)##`)
var str = `This is some text
<p>##IDOBJECT=784##</p> and another some text
<p>##IDOBJECT=1509##</p>
<p>##LATESTARTICLESHOME=321##</p>
<p align=\"center\">##IDOBJECT=321##</p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}