using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=:name=>"")[^""]+";
string input = @"{:name=>""krill"", :priority=>2, :count=>1}, {:name=>""vit a"", :priority=>2]}, {:name=>""vit-b"", :priority=>2, :count=>1}, {:name=>""vit q10"", :priority=>2]}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}