re = /(?<=:name=>")[^"]+/m
str = '{:name=>"krill", :priority=>2, :count=>1}, {:name=>"vit a", :priority=>2]}, {:name=>"vit-b", :priority=>2, :count=>1}, {:name=>"vit q10", :priority=>2]}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end