using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\b[a-z][a-zA-Z]*)(?=[A-Za-z]*\b)([A-Z][a-z]+|[A-Z]+|(?<=[A-Z]+)[a-z]+)";
string substitution = @"_$1";
string input = @"parsingHTTPorSomeURLrequestToday enhanceThisGold thisIsCOOL
xP anotherACRONYMiTest loadedTHISupLIKEaMaDmAnS NoReplacement NONEok
None none n";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}