const regex = /(?<=\b[a-z][a-zA-Z]*)(?=[A-Za-z]*\b)([A-Z][a-z]+|[A-Z]+|(?<=[A-Z]+)[a-z]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\b[a-z][a-zA-Z]*)(?=[A-Za-z]*\\b)([A-Z][a-z]+|[A-Z]+|(?<=[A-Z]+)[a-z]+)', 'gm')
const str = `parsingHTTPorSomeURLrequestToday enhanceThisGold thisIsCOOL
xP anotherACRONYMiTest loadedTHISupLIKEaMaDmAnS NoReplacement NONEok
None none n`;
const subst = `_$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);