$re = '/^([1-9]\d*|0)(\.\d+|)$/m';
$str = '0.15
000123
00.15
1.5
1
90
00
0
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);