import re
regex = re.compile(r"^([1-9]\d*|0)(\.\d+|)$", flags=re.MULTILINE)
test_str = ("0.15\n"
"000123\n"
"00.15\n"
"1.5\n"
"1\n"
"90\n"
"00\n"
"0\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")