using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<p>(?:(?!</p>).)*</p>\s*<p class="".*?</p>";
string input = @"<p>...</p>
<p>...</p>
<p>...</p>
<p class="">... </p>";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}