$re = '~<p>(?:(?!</p>).)*</p>\s*<p class="".*?</p>~si';
$str = '<p>...</p>
<p>...</p>
<p>...</p>
<p class="">... </p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);