package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*([\+|-]?\d*)(\.\d{0,4})?\d*([Ee][\+|-]?\d+)?\s*[,]?`)
var str = ` +123.456789E+0 , 5 +66 -77. 88.E-8 1.570796`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}