$re = '/\s*([\+|-]?\d*)(\.\d{0,4})?\d*([Ee][\+|-]?\d+)?\s*[,]?/m';
$str = ' +123.456789E+0 , 5 +66 -77. 88.E-8 1.570796';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);