#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[a-zA-Z\h]{2,75}$)[A-Z][a-zA-Z]*(?:\h+[A-Z][a-zA-Z]*)*$"
Local $sString = "This Is A Name" & @CRLF & _
"Te" & @CRLF & _
"This Is A Name This Is A Name This Is A Name This Is A Name This Is A Name This Is A Name"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")