using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[a-zA-Z\h]{2,75}$)[A-Z][a-zA-Z]*(?:\h+[A-Z][a-zA-Z]*)*$";
string input = @"This Is A Name
Te
This Is A Name This Is A Name This Is A Name This Is A Name This Is A Name This Is A Name";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}